Cloud Song Uploading on website
Incident Report for MultiTracks.com
Resolved
We believe the issue impacting the upload of Cloud Songs has been resolved. We are continuing to monitor.
Posted Apr 08, 2024 - 12:34 CDT
Investigating
We are currently investigating an issue affecting the ability to upload cloud song tracks on the website.
Posted Apr 08, 2024 - 11:35 CDT
This incident affected: Website.