Cloud Song Uploading
Incident Report for MultiTracks.com
Resolved
This issue has been resolved.
Posted Feb 20, 2023 - 13:07 CST
Investigating
We are currently investigating an issue affecting the ability to add a new song to the library from the website. (Cloud songs and other new library songs manually)
Posted Feb 20, 2023 - 12:16 CST
This incident affected: Website.