Currently investigating issues connecting to our servers in Playback
Incident Report for MultiTracks.com
Resolved
We have identified and resolved the issue.
Posted Mar 06, 2023 - 14:53 CST
Investigating
We are currently investigating an issue affecting Playback and website connections to MultiTracks.com servers.
Posted Mar 06, 2023 - 14:48 CST
This incident affected: Website and Playback App (MacOS, iPadOS, & iOS).