🛠️ Playback Remote Issue in Playback 8.4.5

Incident Report for MultiTracks.com

Monitoring

Version 8.4.6 is now available in the App Store. Please update all devices in order to resolve Playback Remote connectivity issues. You can update directly here: https://apps.apple.com/us/app/playback/id751755884
Posted Nov 01, 2025 - 17:29 CDT

Update

We have submitted Playback 8.4.6 to Apple for expedited review.
Posted Oct 31, 2025 - 14:50 CDT

Identified

We’ve identified a critical issue affecting Playback Remote functionality in version 8.4.5 of the Playback app. Our team has developed a hot-fix, and a new build is currently undergoing internal testing.

Once approved, the updated version will be submitted to the App Store for expedited review and release. We’ll provide updates as soon as the new build is available for download.
Posted Oct 31, 2025 - 09:33 CDT
This incident affects: Playback App (MacOS, iPadOS, & iOS).