Azure Service Outage impacting MultiTracks.com Services

Incident Report for MultiTracks.com

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 07:24 CDT

Update

The Microsoft Azure outage is close to fully resolved; it is still recommended to upgrade to Playback v8.4.5 from the App Store directly here:
https://apps.apple.com/us/app/playback/id751755884
Posted Oct 29, 2025 - 17:00 CDT

Update

We're continuing to monitor the Microsoft Azure Outages. For access in Playback, we're actively beta testing Playback v8.4.5, that mitigates the Azure outage issues. This is available through beta, and we're working to get it out in the App Store which you'll be able to find here: https://apps.apple.com/us/app/playback/id751755884
Posted Oct 29, 2025 - 15:27 CDT

Monitoring

We're continuing to monitor the Microsoft Azure Outages.
Posted Oct 29, 2025 - 15:22 CDT

Identified

Azure Latency and outages is currently impacting MultiTracks.com server and data operations.
Posted Oct 29, 2025 - 11:50 CDT

Investigating

Azure Latency and outages is currently impacting MultiTracks.com server and data operations.
Posted Oct 29, 2025 - 11:35 CDT
This incident affected: Website, Playback App (MacOS, iPadOS, & iOS), and ChartBuilder App.